|
|
本帖最后由 huangjianan 于 2019-12-21 10:11 编辑
2 c% b& W' g, Z _2 f; e) I) F9 P) T! j* _1 c- a
解决tail命令提示“tail: inotify 资源耗尽,无法使用 inotify 机制,回归为 polling 机制”
2 C7 J j& O, `报错的原因是 inotify 跟踪的文件数量超出了系统设置的上限值,要是这个问题不经常出现可以使用临时解决方法,或者写入配置文件来永久解决。 临时解决方法: # 查看 inotify 的相关配置$ sysctl fs.inotify
7 X _/ g5 t- U9 q/ u; N6 }+ K3 kfs.inotify.max_queued_events = 16384) y; p3 f# ?) K/ \0 J6 K3 [/ ]9 R
fs.inotify.max_user_instances = 128
- P/ W- r2 L0 \$ hfs.inotify.max_user_watches = 8192
/ H' t! M+ H% p) N7 _ H0 \# 临时修改配置(重启后会恢复)
3 l- Y3 h8 U% c+ H+ }8 m$ sudo sysctl -w fs.inotify.max_user_watches=100000
) y/ Q- e. z& m6 C* J P' @$ Z: u1 \
永久解决方法:2 I+ x' x. ~; w
$ echo fs.inotify.max_user_watches=100000 | sudo tee -a /etc/sysctl.conf8 F# }7 q* n5 K: o2 }1 M5 G* E2 ^8 \
# 重载配置文件,使之马上生效7 E7 v8 k6 M0 v6 ]/ T6 _" v
$ sudo sysctl -p% z. k& j! T9 m1 Z2 n' B
$ I- N6 _3 F7 w r3 F
6 @& Q, O5 V0 v: ]7 ?+ f |
|