|
|
本帖最后由 huangjianan 于 2019-12-21 10:11 编辑
! i- | m* y3 d# {) _
A( ?/ h* M/ K" g2 P! D/ u4 \8 u0 B; r解决tail命令提示“tail: inotify 资源耗尽,无法使用 inotify 机制,回归为 polling 机制”
4 |1 u$ f" t' i5 _ c4 k' x报错的原因是 inotify 跟踪的文件数量超出了系统设置的上限值,要是这个问题不经常出现可以使用临时解决方法,或者写入配置文件来永久解决。 临时解决方法: # 查看 inotify 的相关配置$ sysctl fs.inotify# Y2 k, C0 h9 f. ^$ [
fs.inotify.max_queued_events = 16384) N4 v# O# q0 q( Y# W0 |2 B
fs.inotify.max_user_instances = 1285 e9 c- c, K& G$ y. f. i& v# b( r
fs.inotify.max_user_watches = 8192% h" {5 g2 i. F0 T
# 临时修改配置(重启后会恢复)# F* I8 H# b6 X, U6 z1 |7 F; f1 g
$ sudo sysctl -w fs.inotify.max_user_watches=100000
" i' I- H. t, [! t2 s' F. ?, y% I) t% `, }+ M0 S( J1 _0 B0 f
永久解决方法:# X6 E- s* Y: {3 B+ w
$ echo fs.inotify.max_user_watches=100000 | sudo tee -a /etc/sysctl.conf( s1 J q8 W4 V3 A0 N, V" a
# 重载配置文件,使之马上生效
5 G# o' X- [, W+ V% g$ sudo sysctl -p( d1 R3 @3 @/ E$ D$ x
: O3 `: |% ~7 r4 H d( h
; v/ Q' ?, k& `. T; W# T3 w+ M' v
|
|